Posts by Harmageddon

Download any EFT version outside of its official way can get you banned.
If we find out that you downloaded EFT on a pirate website you'll be banned without further informations.

You need to own the game and keep it installed on your computer to play AKI.

    A few people have been having this problem. It appears to be a corrupted profile. It is not a server configuration problem.


    If you back up your current profile and start a new one, it will work flawlessly. If you put your old profile back in, it will refuse to load again. I struggled with this for a few hours last week. If you make a new profile and copy and paste portions of your old profile into it, you can retain your skills, inventory, etc. You just have to trial and error copy and paste until you find where the corrupted profile section is and omit that section.


    I recommend the "Save Before Raid" mod to back up your profile every raid. SPT profiles corrupt fairly often, about once a month in my experience.


    This is a similar topic: server loads mods and fuel in generator and then nothing else


    I'm guessing you don't have any fuel in your generator, which is why it doesn't give you that line before hanging indefinitely.


    If anyone else has any more info, feel free to correct me, but in my experience that sever log format indicates a bad profile.

    I just had that happen today on 1.6.0. Black screen after extracting from woods, never got to end of raid screens. Had to Alt+F4 to close the client. After restarting server, I had the same corrupted profile issue.


    I'm not sure what is corrupted in the profile, but you can back up your profile, make a new one, and copy and paste portions of the old profile into the new profile one by one. I got my level, inventory, and skills in successfully, after that I kept getting crashes. Copy section by section, starting with what is most important, and you can probably narrow down where the bad value is.


    After messing with it for about an hour, I said screw it and installed bleeding edge for that 12.11 content. As long as you can go without a few of the mods for a bit, its a much better experience than 1.5.1 or 1.6.0. Insurance, health, trading, food/water all work correctly in bleeding edge, there is a bunch of new content, and Lua's spawn rework is already updated for 2.0.0. Now we just need Configurator and All In One updated to fix weather and loose loot.


    As a preventative measure moving forward, I recommend seeing if the mod Save Before Raid (Save Before Raid) is working. It is for 1.4, but nothing has changed about the save directory, so it should work. It copies your profile into a backup archive before every raid so that you lose at most 1 raid of progress. Honestly, that should be standard for SPT AKI anyways, profiles get corrupted so often that I typically play for about a month before my profiles get corrupted and I have to start over.

    Raider spawns higher than normal. I changed all "raider waves" to 1 wave of 1 to 2 raiders, however I encountered 4 waves of 3 raiders each on woods. My scav, sniper, and PMC spawn tweaks all came through but raiders seem to spawn higher than they should. Do you recommend moving to the latest release? I am on the 12.10 stable branch version.

    Yeah, sometimes I get out of raid whiteout getting shot at all, but it shows me at 30% "just died" health when I extract and allows me to heal, but the screen has no indicators of what I was hit by. If I decide not to heal, I am in fact hurt in the stash screen.


    I have never had insurance carry over from one raid to another. I'm about 80 raids in.

    Upon sorting stash, sorting hangs indefinitely, does not provide a error message and requires restarting the game client to resolve.


    Server shows the following text at point of hang-up:


    [22408bb9a2932af98a15610a][127.0.0.1] /client/game/profile/items/moving

    [ERROR] Trace:

    TypeError: info.data is not iterable

    at Function.handleEvents (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:55873:27)

    at Object.handleEvents [as aki] (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:47282:49)

    at Function.getResponse (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:55817:57)

    at Function.sendResponse (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:56042:29)

    at Inflate.cb (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:56077:22)

    at Inflate.zlibBufferOnError (zlib.js:138:8)

    at Inflate.emit (events.js:315:20)

    at emitErrorNT (internal/streams/destroy.js:106:8)

    at emitErrorCloseNT (internal/streams/destroy.js:74:3)

    at processTicksAndRejections (internal/process/task_queues.js:80:21)

    [ERROR] Trace:

    TypeError: info.data is not iterable

    at Function.handleEvents (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:55873:27)

    at Object.handleEvents [as aki] (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:47282:49)

    at Function.getResponse (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:55817:57)

    at Function.sendResponse (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:56042:29)

    at Inflate.cb (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:56077:22)

    at Inflate.zlibBufferOnError (zlib.js:138:8)

    at Inflate.emit (events.js:315:20)

    at emitErrorNT (internal/streams/destroy.js:106:8)

    at emitErrorCloseNT (internal/streams/destroy.js:74:3)

    at processTicksAndRejections (internal/process/task_queues.js:80:21)

    Additional info regarding insurance.


    I insure an item.

    I survive the raid and retain the item in my inventory, no insurance fraud.

    The insurance status of the item is wiped and I get a message from Therapist with the usual "we sent someone to get your stuff back" message.

    Approx. 24 hours later, I get a duplicate of the item that I insured despite never losing it in raid.


    Something is jacked within how insurance works this time around.

    Hit "fill items" at the bottom to auto-fill for all purchases. You'll need to click off the item the first time and click back on it. After that, the "Deal" button will appear up top. As long as that works, you're not experiencing a bug, thats just how buying works.

    And it looks like something similar happens when I just move things around in my inventory. I was trying to consolidate items after sorting my inventory so that I could run one more raid before my inventory is full. While moving a rig from one place in my stash to another, I got the following error on my server log:


    [ERROR] Trace:

    TypeError: InsuranceController.remove is not a function

    at Function.discardItem (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:50668:25)

    at Object.removeItem [as aki] (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:47225:32)

    at Function.handleEvents (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:55878:66)

    at Object.handleEvents [as aki] (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:47282:49)

    at Function.getResponse (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:55817:57)

    at Function.sendResponse (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:56042:29)

    at Inflate.cb (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:56077:22)

    at Inflate.zlibBufferOnEnd (zlib.js:153:10)

    at Inflate.emit (events.js:315:20)

    at endReadableNT (internal/streams/readable.js:1327:12)


    Edit: Apologies, my mistake, that is just when the game timed out. The error happened when trying to delete a stack of luger CCI from my inventory. Deleting unneeded items its just so second nature that it didn't register. The luger CCI was obviously not insured since it is ammunition.

    Yeah, its a pretty game breaking bug.


    It looks like this also happens when attempting to build anything in the hideout that takes an item from your inventory.


    So far it has happened every time an item attempts to leave my inventory via sale, deletion, or hideout use. It does not happen when turning in items to traders for quests.


    At the moment, it means no way to get money, clear inventory, build hideout modules, etc.

    Error when selling any item to any trader. When hitting the button to complete the sale, the server error pops up:


    ReferenceError: id is not defined

    at Function.removeItem (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:50645:16)

    at Function.sellItem (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:54050:40)

    at Function.confirmTrading (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:54075:30)

    at Object.processTrade [as aki] (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:47773:28)

    at Function.handleEvents (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:55878:66)

    at Object.handleEvents [as aki] (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:47282:49)

    at Function.getResponse (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:55817:57)

    at Function.sendResponse (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:56042:29)

    at Inflate.cb (C:\Program Files (x86)\SPT-AKI\obj\bundle.js:56077:22)

    at Inflate.zlibBufferOnEnd (zlib.js:153:10)


    This also happens when deleting any item from my stash.


    The endless wheel pops up and the item blinks for a minute, then the game receives a critical error and closes.


    Looking at the error log, its appears to be a parent item problem.